Compatible script : PHP Arcade Script V3.0 and above.

Live demo : not available

Download : zip

Terms of usage : Footer links to addicting-games.org.uk and arcadevoid.com must remain intact. Your phpas installation must be licenced.